new pyr pups

Discussion in 'Precious Protectors' started by amyrob, Feb 9, 2008.

  1. amyrob

    amyrob New Member

    14
    Nov 19, 2007
    NW Montana
    If this works, I am showing off our new pyr pups. It is a first litter for Tundra. 6 born but 2 already gone when we found them. She went off for 2 days and we were frantic. She had them in the attic of our root cellar. It's so neat to see the natural instinct. We brought her back to the mud room which we entirely cleaned and prepared for her delivery!!! Shortly after, a 3rd one died. All 3 left are little ladies.

    I can't post the pics. What site are most of you using for posting pics so I can add them here?

    I'll try as an attachment, then send the other pic in the next post.
     
  2. FarmGirl18

    FarmGirl18 New Member

    Oct 5, 2007
    Oklahoma
    The attachments worked!! They are so cute!! Most of us on here use Photo Bucket for posting pics. (http://www.photobucket.com)
     

  3. amyrob

    amyrob New Member

    14
    Nov 19, 2007
    NW Montana
    Why can't I see them?
     
  4. amyrob

    amyrob New Member

    14
    Nov 19, 2007
    NW Montana
    Forget it!! Now I do, slow loading, i guess!
     
  5. lacy_94

    lacy_94 New Member

    192
    Oct 6, 2007
    North Fla
    aww so cute sorry you lossed some
     
  6. alyssa_romine

    alyssa_romine Breaking Dawn Ranch

    Oct 4, 2007
    arkansas
    those are cute puppies!
     
  7. amyrob

    amyrob New Member

    14
    Nov 19, 2007
    NW Montana
    Thanks. I think she is doing very well w/ 3. Maybe 6 was just too many for her as a first time mommy. You know the saying that God doesn't give us more than we can handle. I think it applies to her. So far she has been gone very little and RUNS back frantically.
     
  8. goathappy

    goathappy New Member

    Oct 5, 2007
    Illinois
    They are cute!! Congrats!! :stars:

    Sorry to hear you lost some though :(
     
  9. Rachel K

    Rachel K New Member

    59
    Jan 6, 2008
    Dyersville, Iowa
    The attachments aren't working for me. :(

    Congratulations however. :)